Bug Report Search is not working?

Discussion in 'Questions, comments, bugs, etc.' started by Beerontwowheels, Jul 4, 2018.

  1. Beerontwowheels

    Beerontwowheels

    Joined:
    Apr 11, 2013
    Location:
    MD
    Trying to search in the homebrew section but it’s not displaying any results. Getting a ‘Search could not be completed. Please try again later.’ message.

    Is this still something being worked on with last night’s maintenance release?
     
  2. Gene

    Gene Administrator Staff Member

    Joined:
    Mar 14, 2013
    Location:
    North Jersey / NYC
    We switched servers and it looked like the underlying search tool was not running on the new one. Fixed now!
     
    Last edited: Jul 4, 2018
  3. Gene

    Gene Administrator Staff Member

    Joined:
    Mar 14, 2013
    Location:
    North Jersey / NYC
    Reopening this bug - Search is “working” but the index doesn’t seem to be rebuilding properly. We’ll work on this.
     
  4. lurchingbeast

    lurchingbeast

    Joined:
    Apr 11, 2013
    Search still sucks. I never used to get errors as often as I do now.
     
    tikk, mborden and Gene like this.
  5. mborden

    mborden

    Joined:
    Sep 29, 2013
    Location:
    Portland, OR
    I've taken to using the Google "site" option for now. You can type "site:talkbeer.com searchterms" and it will search just this site for whatever. It's been my fallback while the indexing hasn't been working.
     
    Fingolfin and lurchingbeast like this.
  6. Gene

    Gene Administrator Staff Member

    Joined:
    Mar 14, 2013
    Location:
    North Jersey / NYC
    Reopening this again.
     
    Gonzoillini and mborden like this.
  7. lurchingbeast

    lurchingbeast

    Joined:
    Apr 11, 2013
    Just searched "NFL thread" in the off topic forum. Checked search titles only and search this forum only.

    First result was The Critic Thread.
     
    tosh and Gonzoillini like this.
  8. Gene

    Gene Administrator Staff Member

    Joined:
    Mar 14, 2013
    Location:
    North Jersey / NYC
    The main issue is that the indexer we’re currently using is quite janky, as evidenced by results like that. Should be an “easy” fix but may take some time.
     
    Gonzoillini likes this.
  9. TxBrew

    TxBrew Administrator Staff Member

    Joined:
    May 13, 2014
    Does it seem better now? I flushed the cache and re-ran it.
     
    abawol01, Gene and Gonzoillini like this.
  10. Search with retsyn. Two mints in one.


    (Link to media)



    (Link to media)

    Really good cover of "Search and Destroy". 4:00 mark for relevant material.
     
  11. beerindex you ain't gotta take that shit. Gene ain't tha boss no mo.
     
    tosh likes this.
  12. lurchingbeast

    lurchingbeast

    Joined:
    Apr 11, 2013
    Nope. Exact same results I got before with the NFL search. Also searched "you were never really here" in the movies thread and got the 'The search could not be completed because the search keywords were too short, too long, or too common.' error.... despite posting exactly those words in that exact order yesterday. Shortened it to 'never really here' and got the same result.

    Can I ask why you guys changed servers/indexers/whatever? The search worked incredibly well before.
     
    Gonzoillini likes this.
  13. mborden

    mborden

    Joined:
    Sep 29, 2013
    Location:
    Portland, OR
    This is still a problem. Perhaps even worse? I searched "mlb" and returned zero search hits. Still using my sweet Google search hack every time I need to find a thread.

    [​IMG]
     
    sliverx, ant880, Fingolfin and 8 others like this.
  14. Yooper

    Yooper Administrator Staff Member

    Joined:
    Jul 4, 2018
    Location:
    Upper Michigan
    We're going to fix this later this weekend. We're looking at Sunday/Monday. I'll keep you posted!
     
  15. TxBrew

    TxBrew Administrator Staff Member

    Joined:
    May 13, 2014
    Right now search is using the default Xenforo technology. We migrated the site to AWS and have to setup Elasticsearch again on AWS. Should be completed this weekend.
     
  16. Yooper

    Yooper Administrator Staff Member

    Joined:
    Jul 4, 2018
    Location:
    Upper Michigan
    This should be fixed now! Please let us know if you have any further issues.
     
  17. mborden

    mborden

    Joined:
    Sep 29, 2013
    Location:
    Portland, OR
    Oh thank jeebus. Thanks for ironing this out! Just confirmed I can find my favorite threads in-house once again.
     
    Gonzoillini and Yooper like this.
  18. cneville

    cneville

    Joined:
    May 3, 2013
    Location:
    A2, MI
    i can't see anyone's posts they've made by clicking through to their profile page since friday. if i click "find all content by xxxx" their most recent post is always friday. which is wrong. i can't even see the post above me if i click through to his profile.
     
    sliverx, Gene, ant880 and 4 others like this.
  19. Gene

    Gene Administrator Staff Member

    Joined:
    Mar 14, 2013
    Location:
    North Jersey / NYC
  20. tosh

    tosh

    Joined:
    Oct 2, 2013
    Location:
    Arg
    Can you tag him in the images not working and the Bad Gateway threads as they seem to be getting worse as the day progresses?

    Thanks